Honda Rebel Forum - Reply to Topic
Thread: Fuse box installation help Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Honda Rebel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
09-05-2014 10:12 PM
Jaxs1968
Thanks

Like the advice. I'm back riding!
05-31-2014 08:35 PM
jax Hi Jax1968, When they run a stop sign there isn't much you can do. Real lucky only a fractured elbow and some damage to your bike.
I got hit by a stop sign runner in Oct of 1969. The bike was totaled so was my left foot and and leg. Took 9 months to get well enough to go back to work and 3 years to finally settle.
Hang in there.
jax
05-31-2014 07:54 PM
Jaxs1968 I can't believe what this jerk did! Got hit on my bike! He Failed to yield, speeding and went through a stop sign! Hard to believe but very little damage to bike, broken mirror, two small dents on gas tank! Me well fractured right elbow, hand numb, possible pinched nerve! This creep was here illegally, no license, but was driving a rented new Lexus, Hope to recoup plenty, was riding the next day! Be careful out there, to be honest if I was in a cage I would have been hit or walking, there was nothing I could do to avoid this A-Hole!!!
05-16-2014 06:45 PM
Jaxs1968 Thanks flitecontrol I'll give it a shot.
05-16-2014 12:33 AM
flitecontrol Dielectric grease will help keep the electrical contacts from corroding as well as providing some lubrication.
05-15-2014 07:40 PM
Jaxs1968 Thanks again I'll try cleaning and using some, lube and the bag sounds like a good idea>
05-15-2014 11:34 AM
flitecontrol Possibly. More likely, the switch needs to be cleaned and relubed. there's a how-to on the procedure stickied in the Wrenching section of the forum. One member suggested working in a large plastic bag so you don't lose the springs and other parts. they have a tendency to fly off once the cover is removed.
05-14-2014 10:28 PM
Jaxs1968 I found the Fuse box and they were all good, could it be the Horn button is damaged?
10-29-2013 01:09 PM
Matt_Tastic Thanks for the warm welcome and thank you Buickguy for the pics, I should be getting the new fuse box in next week so I'll post anything if I have any problems.
10-27-2013 09:50 AM
flitecontrol Welcome to the forum! Hope you get it all sorted out soon.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome