Honda Rebel Forum - Reply to Topic
Thread: Tail light not working Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Honda Rebel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-16-2019 12:04 AM
Derienzo10 I will definitely better but from what I recal it was clean it has a few electrical problems the left turning single doesn’t work I believe the relay is bad and the speedometer is broke but other that bike is great runs good
06-15-2019 11:55 PM
flitecontrol Welcome to the forum. When you changed the bulb, was the socket corroded? If yes, it's possible that's the cause, and some light sanding may help. It's a dual filament bulb and sometimes one of the filaments is bad, even on a new bulb.
06-15-2019 11:53 PM
Derienzo10 I will try that thank you
06-15-2019 11:27 PM
SoakedKarma Check your tail lamp fuse.. should be the middle one of the five fuses..
06-15-2019 10:52 PM
Derienzo10
Tail light not working

Hey guys so I just a 87cmx 450 and I’m new to bikes I’ve found out that it’s hard to find parts for the bike but I noticed my tail light is not working but the brake light goes on I changed the bulb still nothing anyone have this issue

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome